$re = '/^(?![abc]{3}).{3}/m';
$str = 'abc
dad
htj
aaa
bcc
jka';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);