$re = '/\b(\w+)\b(?=.*\b\1\b)/';
$str = 'the birds bathe in water';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);