$re = '/(.*?)(?:[;|,](?:q=.*?[,|;])?)/';
$str = 'fr-CH, fr;q=0.9, en;q=0.8, de;q=0.7, *;q=0.5
en-US,en;q=0.9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);