$re = '/\[\/[custombbcode]+]/iu';
$str = '[[[[custombbcode]]title [[[[/custombbcode]] title';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);