$re = '/^.*?\s.*$/m';
$str = '/path/to/file many end.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);