re = /@(?!example|test)[A-Za-z0-9._]+/m
str = '@example
@test
@anythingeelse
@test.stuff
@t_e_s_t'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end