package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-2][0-5]{2}|\d{2}|\d).([0-2][0-5]{2}|\d{2}|\d).([0-2][0-5]{2}|\d{2}|\d).([0-2][0-5]{2}|\d{2}|\d)`)
var str = `180.199.10.175
123$123!123*123
000&000&000&000
1061235`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}