$re = '/(?|^(\w+)|\G(?!^)\h+(\w+))(?:\h+<([^<>\r\n]+)>)?/m';
$str = 'Some User Name
Some User Name <user.mail@address>
<user.mail@address>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);