$re = '/\S+, \S+/m';
$str = 'Mustermann, André
Mustermann, Max-Peter
Mustermann, Max';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);