#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/+\R\K(?:(?!/+$|\d+(?:,\d+)*\R\d+(?:,\d+)*$).*\R)*\d+(?:,\d+)*(?:\R\d+(?:,\d+)*)+(?:\R(?!/+$).*)*(?=\R/+$)"
Local $sString = "/////////////////////////" & @CRLF & _
"Mitnhnhnksmuion" & @CRLF & _
"2,687,064" & @CRLF & _
"Etyjyjes" & @CRLF & _
"1,897,331" & @CRLF & _
"Pihjloyd" & @CRLF & _
"1,466,137" & @CRLF & _
"Edddlnnnnney" & @CRLF & _
"1,297,624" & @CRLF & _
"Thjtyjkujkes" & @CRLF & _
"1,241,307" & @CRLF & _
"Fnnhhnac" & @CRLF & _
"1,159,710" & @CRLF & _
"AfdBhhhghghBA" & @CRLF & _
"1,113,062" & @CRLF & _
"Elnhhyhjkukjhn" & @CRLF & _
"1,023,500" & @CRLF & _
"Bggggggel" & @CRLF & _
"1,009,075" & @CRLF & _
"Letjyjnhhtrh" & @CRLF & _
"991,284" & @CRLF & _
"Bahtyjtjyjd" & @CRLF & _
"849,265" & @CRLF & _
"1980Q4" & @CRLF & _
"/////////////////////////" & @CRLF & _
"Eayes" & @CRLF & _
"4,228,223" & @CRLF & _
"Elhyjtyjey" & @CRLF & _
"1,456,729" & @CRLF & _
"1,412,750" & @CRLF & _
"Lein" & @CRLF & _
"243" & @CRLF & _
"184" & @CRLF & _
"AA" & @CRLF & _
"1,129" & @CRLF & _
"672" & @CRLF & _
"Elejntyj345hn" & @CRLF & _
"002,570" & @CRLF & _
"Neerthty34ond" & @CRLF & _
"916" & @CRLF & _
"78" & @CRLF & _
"Biwertetoel" & @CRLF & _
"910,353" & @CRLF & _
"Qen" & @CRLF & _
"874,812" & @CRLF & _
"Bs" & @CRLF & _
"877,293" & @CRLF & _
"Pyd" & @CRLF & _
"850,146" & @CRLF & _
"1978Q1" & @CRLF & _
"/////////////////////////" & @CRLF & _
"Mteichrtertson" & @CRLF & _
"2,747,969" & @CRLF & _
"Eatertglertees" & @CRLF & _
"1,885,332" & @CRLF & _
"Pirtertd" & @CRLF & _
"1,490,156" & @CRLF & _
"Elverts" & @CRLF & _
"1,295,789" & @CRLF & _
"TtrrheBerteaerttles" & @CRLF & _
"1,239,194" & @CRLF & _
"Fleterteter" & @CRLF & _
"1,156,907" & @CRLF & _
"ABB" & @CRLF & _
"1,117,183" & @CRLF & _
"E" & @CRLF & _
"1,027,583" & @CRLF & _
"Bi" & @CRLF & _
"1,010,372" & @CRLF & _
"LedZ" & @CRLF & _
"987,821" & @CRLF & _
"Barb" & @CRLF & _
"850,687" & @CRLF & _
"1980Q4" & @CRLF & _
"/////////////////////////"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")