const regex = /\b(([01]\d{2}|2[0-4]\d|25[0-5]|\d{1,2})\.){3}(?2)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(([01]\\d{2}|2[0-4]\\d|25[0-5]|\\d{1,2})\\.){3}(?2)\\b', 'gm')
const str = ` 192.168.0.219 192.168.0.21 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}