const regex = /^(\w+(?:[\.-]?\w+)*)@(\w+(?:[\.-]?\w+)*)(\.[a-zA-Z]{2,})+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+(?:[\\.-]?\\w+)*)@(\\w+(?:[\\.-]?\\w+)*)(\\.[a-zA-Z]{2,})+$', 'g')
const str = `12123123@123123gjlk1.co2123.casf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}