re = /^\[(.*?)\] \[(.*?)\] \[(.*?)\] (\/.*?)(\?.*)?$/m
str = '[txt1] [txt2] [txt3] /some/long/path?params=1,2,3
[txt1] [txt2] [txt3] /path/
[txt1] [txt2] [txt3] /'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end