$re = '/^block-redirect-https?://www\.\w+\.\w+$/m';
$str = 'block-redirect-https://www.arubanetworks.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);