$re = '/\b\d(?:\s?\d|\d\s)\d/m';
$str = '150 EUR 15 000 EUR 150 150 EUR 1 500 EUR
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);