package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z0-9\/.&\s-]`)
var str = `abc
@
123
AsxA/
xyz.&
a/-& .
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}