re = /(?<=^[^\r\n=]*?)\./m
str = 'case pencil.tip.crop.circle.badge.plus = "pencil.tip.crop.circle.badge.plus"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end