$re = '~(?<![+*/-])[+*/-]~m';
$str = '5*i+-6-7+-i*5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);