using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-|\+)?[0-9]+[a-z]\^(-|\+)?[0-9]+";
string input = @"4x^3-9x^2+10x-5-45x^-1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}