package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^|]*\|){10}([^|]*)`)
var str = `Info device Allow:FWD|TCP|data1|data2|data3|data4|data5|data6|data7|data8|data9|data10|data11|0|1|0|0|0|0||||||
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}