re = /^\d*(?:\d?[1-9]|[1-9]\d)$/m
str = '22442140100
23501
23510
12
120
1200
2
23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end