$re = '/(\w+)=?([^&]+)?/m';
$str = 'a=1&b=second&c=hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);