$re = '/\b((?:https?://|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}/)(?:[^\s()<>]|\(([^\s()<>]+|(\([^\s()<>]+\)))*\))+(?:\(([^\s()<>]+|(\([^\s()<>]+\)))*\)|[^\s`!()\[\]{};:\'\"\\\\\/.,<>?\xab\xbb\u201c\u201d\u2018\u2019]))/m';
$str = ' on <a href=\\"http://Download%20(Album%20of%20six%20wallpapers)\\"><b>zazev</b></a>.</p>\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);