import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " (?<alpha>[a-z])\n"
+ " (?<digit>[0-9])\n"
+ " (?<unreserved>\\g<alpha>|\\g<digit>|-|\\.|_|~)\n"
+ " (?<hexdig>\\g<digit>|[A-F])\n"
+ " (?<pct_encoded>%\\g<hexdig>{2})\n"
+ " (?<gen_delims>[:\\/\\?\\#\\[\\]@])\n"
+ " (?<sub_delims>[!\\$&'\\(\\)\\*\\+,;=])\n"
+ " (?<reserved>\\g<gen_delims>|\\g<sub_delims>)\n\n"
+ " (?<ip_literal>\\[(?:\\g<ipv6address>|\\g<ipvfuture>)\\])\n"
+ " (?<ipvfuture>v\\g<hexdig>+\\.(?:\\g<unreserved>|\\g<sub_delims>|:)+)\n"
+ " (?<ipv6address>\n"
+ " (?:\\g<h16>:){6}\\g<ls32> |\n"
+ " ::(?:\\g<h16>:){5}\\g<ls32> |\n"
+ " (?: \\g<h16>)?::(?:\\g<h16>:){4}\\g<ls32> |\n"
+ " (?:(?:\\g<h16>:){0,1}\\g<h16>)?::(?:\\g<h16>:){3}\\g<ls32> |\n"
+ " (?:(?:\\g<h16>:){0,2}\\g<h16>)?::(?:\\g<h16>:){2}\\g<ls32> |\n"
+ " (?:(?:\\g<h16>:){0,3}\\g<h16>)?::(?:\\g<h16>:){1}\\g<ls32> |\n"
+ " (?:(?:\\g<h16>:){0,4}\\g<h16>)?:: \\g<ls32> |\n"
+ " (?:(?:\\g<h16>:){0,5}\\g<h16>)?:: \\g<h16> |\n"
+ " (?:(?:\\g<h16>:){0,6}\\g<h16>)?::\n"
+ " )\n"
+ " (?<h16>\\g<hexdig>{1,4})\n"
+ " (?<ls32>\\g<h16>:\\g<h16>|\\g<ipv4address>)\n\n"
+ " (?<ipv4address>\\g<dec_octet>\\.\\g<dec_octet>\\.\\g<dec_octet>\\.\\g<dec_octet>)\n"
+ " (?<dec_octet>\n"
+ " 25[0-5] | # 250-255\n"
+ " 2[0-4]\\g<digit> | # 200-249\n"
+ " 1\\g<digit>{2} | # 100-199\n"
+ " [1-9]\\g<digit> | # 10-99\n"
+ " \\g<digit> # 0-9\n"
+ " )\n"
+ " (?<reg_name>(?:\\g<unreserved>|\\g<pct_encoded>|\\g<sub_delims>)*)\n"
+ " \n"
+ " (?<path_abempty>(?:\\/\\g<segment>)*)\n"
+ " (?<path_absoloute>\\/(?:\\g<segment_nz>(?:\\/\\g<segment>)*))\n"
+ " (?<path_noscheme>\\g<segment_nz_nc>(?:\\/\\g<segment>)*)\n"
+ " (?<path_rootless>\\g<segment_nz>(?:\\/\\g<segment>)*)\n"
+ " (?<path_empty>)\n"
+ " \n"
+ " (?<segment> \\g<pchar>*)\n"
+ " (?<segment_nz> \\g<pchar>+)\n"
+ " (?<segment_nz_nc>(?:\\g<unreserved>|\\g<pct_encoded>|\\g<sub_delims>|@)+) # non-zero-length segment without any colon \":\"\n"
+ " \n"
+ " (?<pchar>\\g<unreserved>|\\g<pct_encoded>|\\g<sub_delims>|:|@)\n"
+ "){0}\n\n"
+ "(?<scheme>\n"
+ " \\g<alpha>\n"
+ " (?:\\g<alpha>|\\g<digit>|\\+|-|\\.)*\n"
+ ")\n"
+ ":\n"
+ "(?<heir_part>\n"
+ " (?:\n"
+ " \\/\\/\n"
+ " (?<authority>\n"
+ " (?:(?<userinfo>(?:\\g<unreserved>|\\g<pct_encoded>|\\g<sub_delims>|:)*)@)?\n"
+ " (?<host>\\g<ip_literal>|\\g<ipv4address>|\\g<reg_name>)\n"
+ " (?::(?<port>\\g<digit>*))?\n"
+ " )\n"
+ " )?\n"
+ " (?<path>(?(<authority>)\n"
+ " \\g<path_abempty> | # begins with \"/\" or is empty\n"
+ " (?:\n"
+ " \\g<path_absoloute> | # begins with \"/\" but not \"//\"\n"
+ " \\g<path_rootless> | # begins with a segment\n"
+ " \\g<path_noscheme> | # begins with a non-colon segment\n"
+ " \\g<path_empty> # zero characters\n"
+ " )\n"
+ " ))\n"
+ ")\n"
+ "(?:\\?(?<query>(?:\\g<pchar>|\\/|\\?)*))?\n"
+ "(?:\\#(?<fragment>(?:\\g<pchar>|\\/|\\?)*))?";
final String string = "ftp://ftp.is.co.za/rfc/rfc1808.txt\n"
+ "http://www.ietf.org/rfc/rfc2396.txt\n"
+ "ldap://[2001:db8::7]/c=GB?objectClass?one\n"
+ "mailto:John.Doe@example.com\n"
+ "news:comp.infosystems.www.servers.unix\n"
+ "tel:+1-816-555-1212\n"
+ "telnet://192.0.2.16:80/\n"
+ "urn:oasis:names:specification:docbook:dtd:xml:4.1.2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}