$re = '/\d(?=(\d{3})+\b)/';
$str = '1234456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);