re = /({\/\* )?#if ((?:(?! \*\/}).)*)( \*\/})?/m
str = '{/* #if process.env.MODE === "std" */}
{/* #if process.env.MODE === "std"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end