import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:)?(?:\\/\\/)?(?:youtu\\.be\\/|(?:www\\.|m\\.)?(?:youtube\\.com|youtube-nocookie\\.com)\\/(watch|v|e|embed|shorts|live)(?:\\.php)?(?:\\?.*v=|\\/))([a-zA-Z0-9\\_-]{7,15})(?:[\\?&][a-zA-Z0-9\\_-]+=[a-zA-Z0-9\\_-]+)*(?:[&\\/\\#].*)?";
final String string = "http://www.youtube.com/watch?v=-wtIMTCHWuI\n"
+ "http://youtube.com/watch?v=-wtIMTCHWuI\n"
+ "http://m.youtube.com/watch?v=-wtIMTCHWuI\n"
+ "https://www.youtube.com/watch?v=lalOy8Mbfdc\n"
+ "https://youtube.com/watch?v=lalOy8Mbfdc\n"
+ "https://m.youtube.com/watch?v=lalOy8Mbfdc\n\n"
+ "http://www.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
+ "http://youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
+ "http://m.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
+ "https://www.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
+ "https://youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
+ "https://m.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "http://youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "http://m.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "https://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "https://youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "https://m.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "http://youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "http://m.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "https://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "https://youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "https://m.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n\n"
+ "http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
+ "http://youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
+ "http://m.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
+ "https://www.youtube.com/watch?v=oTJRivZTMLs&feature=channel\n"
+ "https://youtube.com/watch?v=oTJRivZTMLs&feature=channel\n"
+ "https://m.youtube.com/watch?v=oTJRivZTMLs&feature=channel\n\n"
+ "http://www.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "http://youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "http://m.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "https://www.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "https://youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "https://m.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n\n"
+ "http://www.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
+ "http://youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
+ "http://m.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
+ "https://www.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
+ "https://youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
+ "https://m.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n\n"
+ "http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://m.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "https://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "https://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "https://m.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n\n"
+ "http://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
+ "http://youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
+ "http://m.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
+ "https://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
+ "https://youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
+ "https://m.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n\n"
+ "http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "http://youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "http://m.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "https://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "https://youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
+ "https://m.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n\n"
+ "http://www.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
+ "http://youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
+ "http://m.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
+ "https://www.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
+ "https://youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
+ "https://m.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n\n\n"
+ "http://www.youtube.com/watch/-wtIMTCHWuI\n"
+ "http://youtube.com/watch/-wtIMTCHWuI\n"
+ "http://m.youtube.com/watch/-wtIMTCHWuI\n"
+ "https://www.youtube.com/watch/-wtIMTCHWuI\n"
+ "https://youtube.com/watch/-wtIMTCHWuI\n"
+ "https://m.youtube.com/watch/-wtIMTCHWuI\n\n"
+ "http://www.youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
+ "http://youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
+ "http://m.youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
+ "https://www.youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
+ "https://youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
+ "https://m.youtube.com/watch/-wtIMTCHWuI?app=desktop\n\n\n"
+ "http://www.youtube.com/v/dQw4w9WgXcQ\n"
+ "http://youtube.com/v/dQw4w9WgXcQ\n"
+ "http://m.youtube.com/v/dQw4w9WgXcQ\n"
+ "https://www.youtube.com/v/dQw4w9WgXcQ\n"
+ "https://youtube.com/v/dQw4w9WgXcQ\n"
+ "https://m.youtube.com/v/dQw4w9WgXcQ\n\n"
+ "http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "http://youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "http://m.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "https://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "https://youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "https://m.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n\n"
+ "http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "http://youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "http://m.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "https://youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "https://m.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n\n"
+ "http://www.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "http://m.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "https://www.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "https://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "https://m.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n\n\n"
+ "http://youtu.be/-wtIMTCHWuI\n"
+ "https://youtu.be/-wtIMTCHWuI\n\n"
+ "http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "https://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player\n\n"
+ "http://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b\n"
+ "https://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b\n\n"
+ "http://youtu.be/oTJRivZTMLs&feature=channel\n"
+ "https://youtu.be/oTJRivZTMLs&feature=channel\n\n"
+ "http://youtu.be/lalOy8Mbfdc?t=1\n"
+ "http://youtu.be/lalOy8Mbfdc?t=1s\n"
+ "https://youtu.be/lalOy8Mbfdc?t=1\n"
+ "https://youtu.be/lalOy8Mbfdc?t=1s\n\n"
+ "http://youtu.be/M9bq_alk-sw?si=B_RZg_I-lLaa7UU-\n"
+ "https://youtu.be/M9bq_alk-sw?si=B_RZg_I-lLaa7UU-\n\n\n"
+ "http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
+ "http://youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
+ "http://m.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
+ "https://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
+ "https://youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
+ "https://m.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n\n\n"
+ "http://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
+ "http://youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
+ "http://m.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
+ "https://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
+ "https://youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
+ "https://m.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n\n"
+ "http://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
+ "http://youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
+ "http://m.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
+ "https://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
+ "https://youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
+ "https://m.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n\n\n"
+ "http://www.youtube.com/embed/lalOy8Mbfdc\n"
+ "http://youtube.com/embed/lalOy8Mbfdc\n"
+ "http://m.youtube.com/embed/lalOy8Mbfdc\n"
+ "https://www.youtube.com/embed/lalOy8Mbfdc\n"
+ "https://youtube.com/embed/lalOy8Mbfdc\n"
+ "https://m.youtube.com/embed/lalOy8Mbfdc\n\n"
+ "http://www.youtube.com/embed/nas1rJpm7wY?rel=0\n"
+ "http://youtube.com/embed/nas1rJpm7wY?rel=0\n"
+ "http://m.youtube.com/embed/nas1rJpm7wY?rel=0\n"
+ "https://www.youtube.com/embed/nas1rJpm7wY?rel=0\n"
+ "https://youtube.com/embed/nas1rJpm7wY?rel=0\n"
+ "https://m.youtube.com/embed/nas1rJpm7wY?rel=0\n\n\n"
+ "http://www.youtube-nocookie.com/embed/lalOy8Mbfdc?rel=0\n"
+ "https://www.youtube-nocookie.com/embed/lalOy8Mbfdc?rel=0\n\n\n"
+ "http://www.youtube.com/e/dQw4w9WgXcQ\n"
+ "http://youtube.com/e/dQw4w9WgXcQ\n"
+ "http://m.youtube.com/e/dQw4w9WgXcQ\n"
+ "https://www.youtube.com/e/dQw4w9WgXcQ\n"
+ "https://youtube.com/e/dQw4w9WgXcQ\n"
+ "https://m.youtube.com/e/dQw4w9WgXcQ\n\n\n"
+ "http://www.youtube.com/shorts/j9rZxAF3C0I\n"
+ "http://youtube.com/shorts/j9rZxAF3C0I\n"
+ "http://m.youtube.com/shorts/j9rZxAF3C0I\n"
+ "https://www.youtube.com/shorts/j9rZxAF3C0I\n"
+ "https://youtube.com/shorts/j9rZxAF3C0I\n"
+ "https://m.youtube.com/shorts/j9rZxAF3C0I\n\n"
+ "http://www.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
+ "http://youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
+ "http://m.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
+ "https://www.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
+ "https://youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
+ "https://m.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n\n\n"
+ "http://www.youtube.com/live/8hBmepWUJoc\n"
+ "http://youtube.com/live/8hBmepWUJoc\n"
+ "http://m.youtube.com/live/8hBmepWUJoc\n"
+ "https://www.youtube.com/live/8hBmepWUJoc\n"
+ "https://youtube.com/live/8hBmepWUJoc\n"
+ "https://m.youtube.com/live/8hBmepWUJoc\n\n"
+ "http://www.youtube.com/live/8hBmepWUJoc?app=desktop\n"
+ "http://youtube.com/live/8hBmepWUJoc?app=desktop\n"
+ "http://m.youtube.com/live/8hBmepWUJoc?app=desktop\n"
+ "https://www.youtube.com/live/8hBmepWUJoc?app=desktop\n"
+ "https://youtube.com/live/8hBmepWUJoc?app=desktop\n"
+ "https://m.youtube.com/live/8hBmepWUJoc?app=desktop";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}