const regex = /^(?! ).+?(?:[^;']|(?:'[^']+'))+;\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?! ).+?(?:[^;\']|(?:\'[^\']+\'))+;\\s*$', 'gm')
const str = `SELECT * FROM database;
SELECT * FROM database WHERE somefield = 'somevalue';
SELECT * FROM database WHERE somefield = "somevalue";
EXPLAIN SELECT * FROM database WHERE somefield = "somevalue";
SELECT * FROM database WHERE somefield = 'somevalue' AND someotherfield = 'somemistypedstring;
SELECTing is hard, though, this is just text!;
SELECT
*
FROM
test_table
WHERE
test_row = 'Testing ; semicolon';
SELECT * FROM another_test_table;
INSERT INTO
table_name
VALUES
(value1,'value which contains semicolon ;;;;',value3,...);
WITH JOIN parcels
WHERE sp;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}