$re = '/\[.{14}14:4B.{2}:(Garuda|Raktapaksa) starts using Ferostorm on (Garuda|Raktapaksa)/m';
$str = '[21:53:54.413] 14:4BDE:Garuda starts using Ferostorm on Garuda.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);