re = /^[^:]+(?:::[^:]+)*$/m
str = 'Customer::Table
Customer::Table::Sub
Customer:Table
Customer::Table:Sub
Customer::::Table'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end