$re = '/.*\p{Cyrillic}.*/m';
$str = '1234
Привет
Kuca KуКу!
abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);