$re = '/(q.*?) /m';
$str = 'Eu quero pegar uma palavra que comece com "q" seguida por um espaço. Lorem ipsum dolor sit amet qfadjsljfasldjflasdjfasdjlfjasdjfasljflasdjflasdjflasdjklfjasdlfjasdljflasdjflasdjlfasdjfjasdlfjasdkljfasdkljfklasdjlfçasd fsdkl fasdlfj asldjfl asdjlf asdljf lasdj flasdjklfjas dlçfjaslçdjfklasdjflasdjlfjasdlfajksdl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);