re = /^[^\w]+?(\w.+?\w)[^\w]*?$/m
str = ', , , someword, , someword, , someword, , '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end