$re = '/^(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])(?=[^0-9]*[0-9])(?!.*(.)\1)(?=[a-zA-Z0-9]*[^A-Za-z0-9\s])\S{8,}$/m';
$str = '2Aaaaaaa#
test
2Aadfefea#
AAAAsrf8
Adreef*ue3fd
1Aeff#
Vishal456!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);