package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`viewBox="([^"]+)"`)
var str = `<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 12 18"><title>A</title><path d="M0,18V4A3.83,3.83,0,0,1,1.19,1.18,3.85,3.85,0,0,1,4,0H8a3.81,3.81,0,0,1,2.8,1.19A3.85,3.85,0,0,1,12,4V18H8V10H4v8ZM4,8H8V4A2,2,0,0,0,6,2a1.92,1.92,0,0,0-1.4.59A1.92,1.92,0,0,0,4,4Z"/></svg>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}