# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d"
test_str = ("DIGIT ZERO 0\n"
"DIGIT ONE 1\n"
"DIGIT TWO 2\n"
"DIGIT THREE 3\n"
"DIGIT FOUR 4\n"
"DIGIT FIVE 5\n"
"DIGIT SIX 6\n"
"DIGIT SEVEN 7\n"
"DIGIT EIGHT 8\n"
"DIGIT NINE 9\n"
"ARABIC-INDIC DIGIT ZERO ٠\n"
"ARABIC-INDIC DIGIT ONE ١\n"
"ARABIC-INDIC DIGIT TWO ٢\n"
"ARABIC-INDIC DIGIT THREE ٣\n"
"ARABIC-INDIC DIGIT FOUR ٤\n"
"ARABIC-INDIC DIGIT FIVE ٥\n"
"ARABIC-INDIC DIGIT SIX ٦\n"
"ARABIC-INDIC DIGIT SEVEN ٧\n"
"ARABIC-INDIC DIGIT EIGHT ٨\n"
"ARABIC-INDIC DIGIT NINE ٩\n"
"EXTENDED ARABIC-INDIC DIGIT ZERO ۰\n"
"EXTENDED ARABIC-INDIC DIGIT ONE ۱\n"
"EXTENDED ARABIC-INDIC DIGIT TWO ۲\n"
"EXTENDED ARABIC-INDIC DIGIT THREE ۳\n"
"EXTENDED ARABIC-INDIC DIGIT FOUR ۴\n"
"EXTENDED ARABIC-INDIC DIGIT FIVE ۵\n"
"EXTENDED ARABIC-INDIC DIGIT SIX ۶\n"
"EXTENDED ARABIC-INDIC DIGIT SEVEN ۷\n"
"EXTENDED ARABIC-INDIC DIGIT EIGHT ۸\n"
"EXTENDED ARABIC-INDIC DIGIT NINE ۹\n"
"NKO DIGIT ZERO ߀\n"
"NKO DIGIT ONE ߁\n"
"NKO DIGIT TWO ߂\n"
"NKO DIGIT THREE ߃\n"
"NKO DIGIT FOUR ߄\n"
"NKO DIGIT FIVE ߅\n"
"NKO DIGIT SIX ߆\n"
"NKO DIGIT SEVEN ߇\n"
"NKO DIGIT EIGHT ߈\n"
"NKO DIGIT NINE ߉\n"
"DEVANAGARI DIGIT ZERO ०\n"
"DEVANAGARI DIGIT ONE १\n"
"DEVANAGARI DIGIT TWO २\n"
"DEVANAGARI DIGIT THREE ३\n"
"DEVANAGARI DIGIT FOUR ४\n"
"DEVANAGARI DIGIT FIVE ५\n"
"DEVANAGARI DIGIT SIX ६\n"
"DEVANAGARI DIGIT SEVEN ७\n"
"DEVANAGARI DIGIT EIGHT ८\n"
"DEVANAGARI DIGIT NINE ९\n"
"BENGALI DIGIT ZERO ০\n"
"BENGALI DIGIT ONE ১\n"
"BENGALI DIGIT TWO ২\n"
"BENGALI DIGIT THREE ৩\n"
"BENGALI DIGIT FOUR ৪\n"
"BENGALI DIGIT FIVE ৫\n"
"BENGALI DIGIT SIX ৬\n"
"BENGALI DIGIT SEVEN ৭\n"
"BENGALI DIGIT EIGHT ৮\n"
"BENGALI DIGIT NINE ৯\n"
"GURMUKHI DIGIT ZERO ੦\n"
"GURMUKHI DIGIT ONE ੧\n"
"GURMUKHI DIGIT TWO ੨\n"
"GURMUKHI DIGIT THREE ੩\n"
"GURMUKHI DIGIT FOUR ੪\n"
"GURMUKHI DIGIT FIVE ੫\n"
"GURMUKHI DIGIT SIX ੬\n"
"GURMUKHI DIGIT SEVEN ੭\n"
"GURMUKHI DIGIT EIGHT ੮\n"
"GURMUKHI DIGIT NINE ੯\n"
"GUJARATI DIGIT ZERO ૦\n"
"GUJARATI DIGIT ONE ૧\n"
"GUJARATI DIGIT TWO ૨\n"
"GUJARATI DIGIT THREE ૩\n"
"GUJARATI DIGIT FOUR ૪\n"
"GUJARATI DIGIT FIVE ૫\n"
"GUJARATI DIGIT SIX ૬\n"
"GUJARATI DIGIT SEVEN ૭\n"
"GUJARATI DIGIT EIGHT ૮\n"
"GUJARATI DIGIT NINE ૯\n"
"ORIYA DIGIT ZERO ୦\n"
"ORIYA DIGIT ONE ୧\n"
"ORIYA DIGIT TWO ୨\n"
"ORIYA DIGIT THREE ୩\n"
"ORIYA DIGIT FOUR ୪\n"
"ORIYA DIGIT FIVE ୫\n"
"ORIYA DIGIT SIX ୬\n"
"ORIYA DIGIT SEVEN ୭\n"
"ORIYA DIGIT EIGHT ୮\n"
"ORIYA DIGIT NINE ୯\n"
"TAMIL DIGIT ZERO ௦\n"
"TAMIL DIGIT ONE ௧\n"
"TAMIL DIGIT TWO ௨\n"
"TAMIL DIGIT THREE ௩\n"
"TAMIL DIGIT FOUR ௪\n"
"TAMIL DIGIT FIVE ௫\n"
"TAMIL DIGIT SIX ௬\n"
"TAMIL DIGIT SEVEN ௭\n"
"TAMIL DIGIT EIGHT ௮\n"
"TAMIL DIGIT NINE ௯\n"
"TELUGU DIGIT ZERO ౦\n"
"TELUGU DIGIT ONE ౧\n"
"TELUGU DIGIT TWO ౨\n"
"TELUGU DIGIT THREE ౩\n"
"TELUGU DIGIT FOUR ౪\n"
"TELUGU DIGIT FIVE ౫\n"
"TELUGU DIGIT SIX ౬\n"
"TELUGU DIGIT SEVEN ౭\n"
"TELUGU DIGIT EIGHT ౮\n"
"TELUGU DIGIT NINE ౯\n"
"KANNADA DIGIT ZERO ೦\n"
"KANNADA DIGIT ONE ೧\n"
"KANNADA DIGIT TWO ೨\n"
"KANNADA DIGIT THREE ೩\n"
"KANNADA DIGIT FOUR ೪\n"
"KANNADA DIGIT FIVE ೫\n"
"KANNADA DIGIT SIX ೬\n"
"KANNADA DIGIT SEVEN ೭\n"
"KANNADA DIGIT EIGHT ೮\n"
"KANNADA DIGIT NINE ೯\n"
"MALAYALAM DIGIT ZERO ൦\n"
"MALAYALAM DIGIT ONE ൧\n"
"MALAYALAM DIGIT TWO ൨\n"
"MALAYALAM DIGIT THREE ൩\n"
"MALAYALAM DIGIT FOUR ൪\n"
"MALAYALAM DIGIT FIVE ൫\n"
"MALAYALAM DIGIT SIX ൬\n"
"MALAYALAM DIGIT SEVEN ൭\n"
"MALAYALAM DIGIT EIGHT ൮\n"
"MALAYALAM DIGIT NINE ൯\n"
"SINHALA LITH DIGIT ZERO ෦\n"
"SINHALA LITH DIGIT ONE ෧\n"
"SINHALA LITH DIGIT TWO ෨\n"
"SINHALA LITH DIGIT THREE ෩\n"
"SINHALA LITH DIGIT FOUR ෪\n"
"SINHALA LITH DIGIT FIVE ෫\n"
"SINHALA LITH DIGIT SIX ෬\n"
"SINHALA LITH DIGIT SEVEN ෭\n"
"SINHALA LITH DIGIT EIGHT ෮\n"
"SINHALA LITH DIGIT NINE ෯\n"
"THAI DIGIT ZERO ๐\n"
"THAI DIGIT ONE ๑\n"
"THAI DIGIT TWO ๒\n"
"THAI DIGIT THREE ๓\n"
"THAI DIGIT FOUR ๔\n"
"THAI DIGIT FIVE ๕\n"
"THAI DIGIT SIX ๖\n"
"THAI DIGIT SEVEN ๗\n"
"THAI DIGIT EIGHT ๘\n"
"THAI DIGIT NINE ๙\n"
"LAO DIGIT ZERO ໐\n"
"LAO DIGIT ONE ໑\n"
"LAO DIGIT TWO ໒\n"
"LAO DIGIT THREE ໓\n"
"LAO DIGIT FOUR ໔\n"
"LAO DIGIT FIVE ໕\n"
"LAO DIGIT SIX ໖\n"
"LAO DIGIT SEVEN ໗\n"
"LAO DIGIT EIGHT ໘\n"
"LAO DIGIT NINE ໙\n"
"TIBETAN DIGIT ZERO ༠\n"
"TIBETAN DIGIT ONE ༡\n"
"TIBETAN DIGIT TWO ༢\n"
"TIBETAN DIGIT THREE ༣\n"
"TIBETAN DIGIT FOUR ༤\n"
"TIBETAN DIGIT FIVE ༥\n"
"TIBETAN DIGIT SIX ༦\n"
"TIBETAN DIGIT SEVEN ༧\n"
"TIBETAN DIGIT EIGHT ༨\n"
"TIBETAN DIGIT NINE ༩\n"
"MYANMAR DIGIT ZERO ၀\n"
"MYANMAR DIGIT ONE ၁\n"
"MYANMAR DIGIT TWO ၂\n"
"MYANMAR DIGIT THREE ၃\n"
"MYANMAR DIGIT FOUR ၄\n"
"MYANMAR DIGIT FIVE ၅\n"
"MYANMAR DIGIT SIX ၆\n"
"MYANMAR DIGIT SEVEN ၇\n"
"MYANMAR DIGIT EIGHT ၈\n"
"MYANMAR DIGIT NINE ၉\n"
"MYANMAR SHAN DIGIT ZERO ႐\n"
"MYANMAR SHAN DIGIT ONE ႑\n"
"MYANMAR SHAN DIGIT TWO ႒\n"
"MYANMAR SHAN DIGIT THREE ႓\n"
"MYANMAR SHAN DIGIT FOUR ႔\n"
"MYANMAR SHAN DIGIT FIVE ႕\n"
"MYANMAR SHAN DIGIT SIX ႖\n"
"MYANMAR SHAN DIGIT SEVEN ႗\n"
"MYANMAR SHAN DIGIT EIGHT ႘\n"
"MYANMAR SHAN DIGIT NINE ႙\n"
"KHMER DIGIT ZERO ០\n"
"KHMER DIGIT ONE ១\n"
"KHMER DIGIT TWO ២\n"
"KHMER DIGIT THREE ៣\n"
"KHMER DIGIT FOUR ៤\n"
"KHMER DIGIT FIVE ៥\n"
"KHMER DIGIT SIX ៦\n"
"KHMER DIGIT SEVEN ៧\n"
"KHMER DIGIT EIGHT ៨\n"
"KHMER DIGIT NINE ៩\n"
"MONGOLIAN DIGIT ZERO ᠐\n"
"MONGOLIAN DIGIT ONE ᠑\n"
"MONGOLIAN DIGIT TWO ᠒\n"
"MONGOLIAN DIGIT THREE ᠓\n"
"MONGOLIAN DIGIT FOUR ᠔\n"
"MONGOLIAN DIGIT FIVE ᠕\n"
"MONGOLIAN DIGIT SIX ᠖\n"
"MONGOLIAN DIGIT SEVEN ᠗\n"
"MONGOLIAN DIGIT EIGHT ᠘\n"
"MONGOLIAN DIGIT NINE ᠙\n"
"LIMBU DIGIT ZERO ᥆\n"
"LIMBU DIGIT ONE ᥇\n"
"LIMBU DIGIT TWO ᥈\n"
"LIMBU DIGIT THREE ᥉\n"
"LIMBU DIGIT FOUR ᥊\n"
"LIMBU DIGIT FIVE ᥋\n"
"LIMBU DIGIT SIX ᥌\n"
"LIMBU DIGIT SEVEN ᥍\n"
"LIMBU DIGIT EIGHT ᥎\n"
"LIMBU DIGIT NINE ᥏\n"
"NEW TAI LUE DIGIT ZERO ᧐\n"
"NEW TAI LUE DIGIT ONE ᧑\n"
"NEW TAI LUE DIGIT TWO ᧒\n"
"NEW TAI LUE DIGIT THREE ᧓\n"
"NEW TAI LUE DIGIT FOUR ᧔\n"
"NEW TAI LUE DIGIT FIVE ᧕\n"
"NEW TAI LUE DIGIT SIX ᧖\n"
"NEW TAI LUE DIGIT SEVEN ᧗\n"
"NEW TAI LUE DIGIT EIGHT ᧘\n"
"NEW TAI LUE DIGIT NINE ᧙\n"
"TAI THAM HORA DIGIT ZERO ᪀\n"
"TAI THAM HORA DIGIT ONE ᪁\n"
"TAI THAM HORA DIGIT TWO ᪂\n"
"TAI THAM HORA DIGIT THREE ᪃\n"
"TAI THAM HORA DIGIT FOUR ᪄\n"
"TAI THAM HORA DIGIT FIVE ᪅\n"
"TAI THAM HORA DIGIT SIX ᪆\n"
"TAI THAM HORA DIGIT SEVEN ᪇\n"
"TAI THAM HORA DIGIT EIGHT ᪈\n"
"TAI THAM HORA DIGIT NINE ᪉\n"
"TAI THAM THAM DIGIT ZERO ᪐\n"
"TAI THAM THAM DIGIT ONE ᪑\n"
"TAI THAM THAM DIGIT TWO ᪒\n"
"TAI THAM THAM DIGIT THREE ᪓\n"
"TAI THAM THAM DIGIT FOUR ᪔\n"
"TAI THAM THAM DIGIT FIVE ᪕\n"
"TAI THAM THAM DIGIT SIX ᪖\n"
"TAI THAM THAM DIGIT SEVEN ᪗\n"
"TAI THAM THAM DIGIT EIGHT ᪘\n"
"TAI THAM THAM DIGIT NINE ᪙\n"
"BALINESE DIGIT ZERO ᭐\n"
"BALINESE DIGIT ONE ᭑\n"
"BALINESE DIGIT TWO ᭒\n"
"BALINESE DIGIT THREE ᭓\n"
"BALINESE DIGIT FOUR ᭔\n"
"BALINESE DIGIT FIVE ᭕\n"
"BALINESE DIGIT SIX ᭖\n"
"BALINESE DIGIT SEVEN ᭗\n"
"BALINESE DIGIT EIGHT ᭘\n"
"BALINESE DIGIT NINE ᭙\n"
"SUNDANESE DIGIT ZERO ᮰\n"
"SUNDANESE DIGIT ONE ᮱\n"
"SUNDANESE DIGIT TWO ᮲\n"
"SUNDANESE DIGIT THREE ᮳\n"
"SUNDANESE DIGIT FOUR ᮴\n"
"SUNDANESE DIGIT FIVE ᮵\n"
"SUNDANESE DIGIT SIX ᮶\n"
"SUNDANESE DIGIT SEVEN ᮷\n"
"SUNDANESE DIGIT EIGHT ᮸\n"
"SUNDANESE DIGIT NINE ᮹\n"
"LEPCHA DIGIT ZERO ᱀\n"
"LEPCHA DIGIT ONE ᱁\n"
"LEPCHA DIGIT TWO ᱂\n"
"LEPCHA DIGIT THREE ᱃\n"
"LEPCHA DIGIT FOUR ᱄\n"
"LEPCHA DIGIT FIVE ᱅\n"
"LEPCHA DIGIT SIX ᱆\n"
"LEPCHA DIGIT SEVEN ᱇\n"
"LEPCHA DIGIT EIGHT ᱈\n"
"LEPCHA DIGIT NINE ᱉\n"
"OL CHIKI DIGIT ZERO ᱐\n"
"OL CHIKI DIGIT ONE ᱑\n"
"OL CHIKI DIGIT TWO ᱒\n"
"OL CHIKI DIGIT THREE ᱓\n"
"OL CHIKI DIGIT FOUR ᱔\n"
"OL CHIKI DIGIT FIVE ᱕\n"
"OL CHIKI DIGIT SIX ᱖\n"
"OL CHIKI DIGIT SEVEN ᱗\n"
"OL CHIKI DIGIT EIGHT ᱘\n"
"OL CHIKI DIGIT NINE ᱙\n"
"VAI DIGIT ZERO ꘠\n"
"VAI DIGIT ONE ꘡\n"
"VAI DIGIT TWO ꘢\n"
"VAI DIGIT THREE ꘣\n"
"VAI DIGIT FOUR ꘤\n"
"VAI DIGIT FIVE ꘥\n"
"VAI DIGIT SIX ꘦\n"
"VAI DIGIT SEVEN ꘧\n"
"VAI DIGIT EIGHT ꘨\n"
"VAI DIGIT NINE ꘩\n"
"SAURASHTRA DIGIT ZERO ꣐\n"
"SAURASHTRA DIGIT ONE ꣑\n"
"SAURASHTRA DIGIT TWO ꣒\n"
"SAURASHTRA DIGIT THREE ꣓\n"
"SAURASHTRA DIGIT FOUR ꣔\n"
"SAURASHTRA DIGIT FIVE ꣕\n"
"SAURASHTRA DIGIT SIX ꣖\n"
"SAURASHTRA DIGIT SEVEN ꣗\n"
"SAURASHTRA DIGIT EIGHT ꣘\n"
"SAURASHTRA DIGIT NINE ꣙\n"
"KAYAH LI DIGIT ZERO ꤀\n"
"KAYAH LI DIGIT ONE ꤁\n"
"KAYAH LI DIGIT TWO ꤂\n"
"KAYAH LI DIGIT THREE ꤃\n"
"KAYAH LI DIGIT FOUR ꤄\n"
"KAYAH LI DIGIT FIVE ꤅\n"
"KAYAH LI DIGIT SIX ꤆\n"
"KAYAH LI DIGIT SEVEN ꤇\n"
"KAYAH LI DIGIT EIGHT ꤈\n"
"KAYAH LI DIGIT NINE ꤉\n"
"JAVANESE DIGIT ZERO ꧐\n"
"JAVANESE DIGIT ONE ꧑\n"
"JAVANESE DIGIT TWO ꧒\n"
"JAVANESE DIGIT THREE ꧓\n"
"JAVANESE DIGIT FOUR ꧔\n"
"JAVANESE DIGIT FIVE ꧕\n"
"JAVANESE DIGIT SIX ꧖\n"
"JAVANESE DIGIT SEVEN ꧗\n"
"JAVANESE DIGIT EIGHT ꧘\n"
"JAVANESE DIGIT NINE ꧙\n"
"MYANMAR TAI LAING DIGIT ZERO ꧰\n"
"MYANMAR TAI LAING DIGIT ONE ꧱\n"
"MYANMAR TAI LAING DIGIT TWO ꧲\n"
"MYANMAR TAI LAING DIGIT THREE ꧳\n"
"MYANMAR TAI LAING DIGIT FOUR ꧴\n"
"MYANMAR TAI LAING DIGIT FIVE ꧵\n"
"MYANMAR TAI LAING DIGIT SIX ꧶\n"
"MYANMAR TAI LAING DIGIT SEVEN ꧷\n"
"MYANMAR TAI LAING DIGIT EIGHT ꧸\n"
"MYANMAR TAI LAING DIGIT NINE ꧹\n"
"CHAM DIGIT ZERO ꩐\n"
"CHAM DIGIT ONE ꩑\n"
"CHAM DIGIT TWO ꩒\n"
"CHAM DIGIT THREE ꩓\n"
"CHAM DIGIT FOUR ꩔\n"
"CHAM DIGIT FIVE ꩕\n"
"CHAM DIGIT SIX ꩖\n"
"CHAM DIGIT SEVEN ꩗\n"
"CHAM DIGIT EIGHT ꩘\n"
"CHAM DIGIT NINE ꩙\n"
"MEETEI MAYEK DIGIT ZERO ꯰\n"
"MEETEI MAYEK DIGIT ONE ꯱\n"
"MEETEI MAYEK DIGIT TWO ꯲\n"
"MEETEI MAYEK DIGIT THREE ꯳\n"
"MEETEI MAYEK DIGIT FOUR ꯴\n"
"MEETEI MAYEK DIGIT FIVE ꯵\n"
"MEETEI MAYEK DIGIT SIX ꯶\n"
"MEETEI MAYEK DIGIT SEVEN ꯷\n"
"MEETEI MAYEK DIGIT EIGHT ꯸\n"
"MEETEI MAYEK DIGIT NINE ꯹\n"
"FULLWIDTH DIGIT ZERO 0\n"
"FULLWIDTH DIGIT ONE 1\n"
"FULLWIDTH DIGIT TWO 2\n"
"FULLWIDTH DIGIT THREE 3\n"
"FULLWIDTH DIGIT FOUR 4\n"
"FULLWIDTH DIGIT FIVE 5\n"
"FULLWIDTH DIGIT SIX 6\n"
"FULLWIDTH DIGIT SEVEN 7\n"
"FULLWIDTH DIGIT EIGHT 8\n"
"FULLWIDTH DIGIT NINE 9\n"
"OSMANYA DIGIT ZERO 𐒠\n"
"OSMANYA DIGIT ONE 𐒡\n"
"OSMANYA DIGIT TWO 𐒢\n"
"OSMANYA DIGIT THREE 𐒣\n"
"OSMANYA DIGIT FOUR 𐒤\n"
"OSMANYA DIGIT FIVE 𐒥\n"
"OSMANYA DIGIT SIX 𐒦\n"
"OSMANYA DIGIT SEVEN 𐒧\n"
"OSMANYA DIGIT EIGHT 𐒨\n"
"OSMANYA DIGIT NINE 𐒩\n"
"HANIFI ROHINGYA DIGIT ZERO 𐴰\n"
"HANIFI ROHINGYA DIGIT ONE 𐴱\n"
"HANIFI ROHINGYA DIGIT TWO 𐴲\n"
"HANIFI ROHINGYA DIGIT THREE 𐴳\n"
"HANIFI ROHINGYA DIGIT FOUR 𐴴\n"
"HANIFI ROHINGYA DIGIT FIVE 𐴵\n"
"HANIFI ROHINGYA DIGIT SIX 𐴶\n"
"HANIFI ROHINGYA DIGIT SEVEN 𐴷\n"
"HANIFI ROHINGYA DIGIT EIGHT 𐴸\n"
"HANIFI ROHINGYA DIGIT NINE 𐴹\n"
"BRAHMI DIGIT ZERO 𑁦\n"
"BRAHMI DIGIT ONE 𑁧\n"
"BRAHMI DIGIT TWO 𑁨\n"
"BRAHMI DIGIT THREE 𑁩\n"
"BRAHMI DIGIT FOUR 𑁪\n"
"BRAHMI DIGIT FIVE 𑁫\n"
"BRAHMI DIGIT SIX 𑁬\n"
"BRAHMI DIGIT SEVEN 𑁭\n"
"BRAHMI DIGIT EIGHT 𑁮\n"
"BRAHMI DIGIT NINE 𑁯\n"
"SORA SOMPENG DIGIT ZERO 𑃰\n"
"SORA SOMPENG DIGIT ONE 𑃱\n"
"SORA SOMPENG DIGIT TWO 𑃲\n"
"SORA SOMPENG DIGIT THREE 𑃳\n"
"SORA SOMPENG DIGIT FOUR 𑃴\n"
"SORA SOMPENG DIGIT FIVE 𑃵\n"
"SORA SOMPENG DIGIT SIX 𑃶\n"
"SORA SOMPENG DIGIT SEVEN 𑃷\n"
"SORA SOMPENG DIGIT EIGHT 𑃸\n"
"SORA SOMPENG DIGIT NINE 𑃹\n"
"CHAKMA DIGIT ZERO 𑄶\n"
"CHAKMA DIGIT ONE 𑄷\n"
"CHAKMA DIGIT TWO 𑄸\n"
"CHAKMA DIGIT THREE 𑄹\n"
"CHAKMA DIGIT FOUR 𑄺\n"
"CHAKMA DIGIT FIVE 𑄻\n"
"CHAKMA DIGIT SIX 𑄼\n"
"CHAKMA DIGIT SEVEN 𑄽\n"
"CHAKMA DIGIT EIGHT 𑄾\n"
"CHAKMA DIGIT NINE 𑄿\n"
"SHARADA DIGIT ZERO 𑇐\n"
"SHARADA DIGIT ONE 𑇑\n"
"SHARADA DIGIT TWO 𑇒\n"
"SHARADA DIGIT THREE 𑇓\n"
"SHARADA DIGIT FOUR 𑇔\n"
"SHARADA DIGIT FIVE 𑇕\n"
"SHARADA DIGIT SIX 𑇖\n"
"SHARADA DIGIT SEVEN 𑇗\n"
"SHARADA DIGIT EIGHT 𑇘\n"
"SHARADA DIGIT NINE 𑇙\n"
"KHUDAWADI DIGIT ZERO 𑋰\n"
"KHUDAWADI DIGIT ONE 𑋱\n"
"KHUDAWADI DIGIT TWO 𑋲\n"
"KHUDAWADI DIGIT THREE 𑋳\n"
"KHUDAWADI DIGIT FOUR 𑋴\n"
"KHUDAWADI DIGIT FIVE 𑋵\n"
"KHUDAWADI DIGIT SIX 𑋶\n"
"KHUDAWADI DIGIT SEVEN 𑋷\n"
"KHUDAWADI DIGIT EIGHT 𑋸\n"
"KHUDAWADI DIGIT NINE 𑋹\n"
"NEWA DIGIT ZERO 𑑐\n"
"NEWA DIGIT ONE 𑑑\n"
"NEWA DIGIT TWO 𑑒\n"
"NEWA DIGIT THREE 𑑓\n"
"NEWA DIGIT FOUR 𑑔\n"
"NEWA DIGIT FIVE 𑑕\n"
"NEWA DIGIT SIX 𑑖\n"
"NEWA DIGIT SEVEN 𑑗\n"
"NEWA DIGIT EIGHT 𑑘\n"
"NEWA DIGIT NINE 𑑙\n"
"TIRHUTA DIGIT ZERO 𑓐\n"
"TIRHUTA DIGIT ONE 𑓑\n"
"TIRHUTA DIGIT TWO 𑓒\n"
"TIRHUTA DIGIT THREE 𑓓\n"
"TIRHUTA DIGIT FOUR 𑓔\n"
"TIRHUTA DIGIT FIVE 𑓕\n"
"TIRHUTA DIGIT SIX 𑓖\n"
"TIRHUTA DIGIT SEVEN 𑓗\n"
"TIRHUTA DIGIT EIGHT 𑓘\n"
"TIRHUTA DIGIT NINE 𑓙\n"
"MODI DIGIT ZERO 𑙐\n"
"MODI DIGIT ONE 𑙑\n"
"MODI DIGIT TWO 𑙒\n"
"MODI DIGIT THREE 𑙓\n"
"MODI DIGIT FOUR 𑙔\n"
"MODI DIGIT FIVE 𑙕\n"
"MODI DIGIT SIX 𑙖\n"
"MODI DIGIT SEVEN 𑙗\n"
"MODI DIGIT EIGHT 𑙘\n"
"MODI DIGIT NINE 𑙙\n"
"TAKRI DIGIT ZERO 𑛀\n"
"TAKRI DIGIT ONE 𑛁\n"
"TAKRI DIGIT TWO 𑛂\n"
"TAKRI DIGIT THREE 𑛃\n"
"TAKRI DIGIT FOUR 𑛄\n"
"TAKRI DIGIT FIVE 𑛅\n"
"TAKRI DIGIT SIX 𑛆\n"
"TAKRI DIGIT SEVEN 𑛇\n"
"TAKRI DIGIT EIGHT 𑛈\n"
"TAKRI DIGIT NINE 𑛉\n"
"AHOM DIGIT ZERO 𑜰\n"
"AHOM DIGIT ONE 𑜱\n"
"AHOM DIGIT TWO 𑜲\n"
"AHOM DIGIT THREE 𑜳\n"
"AHOM DIGIT FOUR 𑜴\n"
"AHOM DIGIT FIVE 𑜵\n"
"AHOM DIGIT SIX 𑜶\n"
"AHOM DIGIT SEVEN 𑜷\n"
"AHOM DIGIT EIGHT 𑜸\n"
"AHOM DIGIT NINE 𑜹\n"
"WARANG CITI DIGIT ZERO 𑣠\n"
"WARANG CITI DIGIT ONE 𑣡\n"
"WARANG CITI DIGIT TWO 𑣢\n"
"WARANG CITI DIGIT THREE 𑣣\n"
"WARANG CITI DIGIT FOUR 𑣤\n"
"WARANG CITI DIGIT FIVE 𑣥\n"
"WARANG CITI DIGIT SIX 𑣦\n"
"WARANG CITI DIGIT SEVEN 𑣧\n"
"WARANG CITI DIGIT EIGHT 𑣨\n"
"WARANG CITI DIGIT NINE 𑣩\n"
"DIVES AKURU DIGIT ZERO 𑥐\n"
"DIVES AKURU DIGIT ONE 𑥑\n"
"DIVES AKURU DIGIT TWO 𑥒\n"
"DIVES AKURU DIGIT THREE 𑥓\n"
"DIVES AKURU DIGIT FOUR 𑥔\n"
"DIVES AKURU DIGIT FIVE 𑥕\n"
"DIVES AKURU DIGIT SIX 𑥖\n"
"DIVES AKURU DIGIT SEVEN 𑥗\n"
"DIVES AKURU DIGIT EIGHT 𑥘\n"
"DIVES AKURU DIGIT NINE 𑥙\n"
"BHAIKSUKI DIGIT ZERO 𑱐\n"
"BHAIKSUKI DIGIT ONE 𑱑\n"
"BHAIKSUKI DIGIT TWO 𑱒\n"
"BHAIKSUKI DIGIT THREE 𑱓\n"
"BHAIKSUKI DIGIT FOUR 𑱔\n"
"BHAIKSUKI DIGIT FIVE 𑱕\n"
"BHAIKSUKI DIGIT SIX 𑱖\n"
"BHAIKSUKI DIGIT SEVEN 𑱗\n"
"BHAIKSUKI DIGIT EIGHT 𑱘\n"
"BHAIKSUKI DIGIT NINE 𑱙\n"
"MASARAM GONDI DIGIT ZERO 𑵐\n"
"MASARAM GONDI DIGIT ONE 𑵑\n"
"MASARAM GONDI DIGIT TWO 𑵒\n"
"MASARAM GONDI DIGIT THREE 𑵓\n"
"MASARAM GONDI DIGIT FOUR 𑵔\n"
"MASARAM GONDI DIGIT FIVE 𑵕\n"
"MASARAM GONDI DIGIT SIX 𑵖\n"
"MASARAM GONDI DIGIT SEVEN 𑵗\n"
"MASARAM GONDI DIGIT EIGHT 𑵘\n"
"MASARAM GONDI DIGIT NINE 𑵙\n"
"GUNJALA GONDI DIGIT ZERO 𑶠\n"
"GUNJALA GONDI DIGIT ONE 𑶡\n"
"GUNJALA GONDI DIGIT TWO 𑶢\n"
"GUNJALA GONDI DIGIT THREE 𑶣\n"
"GUNJALA GONDI DIGIT FOUR 𑶤\n"
"GUNJALA GONDI DIGIT FIVE 𑶥\n"
"GUNJALA GONDI DIGIT SIX 𑶦\n"
"GUNJALA GONDI DIGIT SEVEN 𑶧\n"
"GUNJALA GONDI DIGIT EIGHT 𑶨\n"
"GUNJALA GONDI DIGIT NINE 𑶩\n"
"KAWI DIGIT ZERO 𑽐\n"
"KAWI DIGIT ONE 𑽑\n"
"KAWI DIGIT TWO 𑽒\n"
"KAWI DIGIT THREE 𑽓\n"
"KAWI DIGIT FOUR 𑽔\n"
"KAWI DIGIT FIVE 𑽕\n"
"KAWI DIGIT SIX 𑽖\n"
"KAWI DIGIT SEVEN 𑽗\n"
"KAWI DIGIT EIGHT 𑽘\n"
"KAWI DIGIT NINE 𑽙\n"
"MRO DIGIT ZERO 𖩠\n"
"MRO DIGIT ONE 𖩡\n"
"MRO DIGIT TWO 𖩢\n"
"MRO DIGIT THREE 𖩣\n"
"MRO DIGIT FOUR 𖩤\n"
"MRO DIGIT FIVE 𖩥\n"
"MRO DIGIT SIX 𖩦\n"
"MRO DIGIT SEVEN 𖩧\n"
"MRO DIGIT EIGHT 𖩨\n"
"MRO DIGIT NINE 𖩩\n"
"TANGSA DIGIT ZERO 𖫀\n"
"TANGSA DIGIT ONE 𖫁\n"
"TANGSA DIGIT TWO 𖫂\n"
"TANGSA DIGIT THREE 𖫃\n"
"TANGSA DIGIT FOUR 𖫄\n"
"TANGSA DIGIT FIVE 𖫅\n"
"TANGSA DIGIT SIX 𖫆\n"
"TANGSA DIGIT SEVEN 𖫇\n"
"TANGSA DIGIT EIGHT 𖫈\n"
"TANGSA DIGIT NINE 𖫉\n"
"PAHAWH HMONG DIGIT ZERO 𖭐\n"
"PAHAWH HMONG DIGIT ONE 𖭑\n"
"PAHAWH HMONG DIGIT TWO 𖭒\n"
"PAHAWH HMONG DIGIT THREE 𖭓\n"
"PAHAWH HMONG DIGIT FOUR 𖭔\n"
"PAHAWH HMONG DIGIT FIVE 𖭕\n"
"PAHAWH HMONG DIGIT SIX 𖭖\n"
"PAHAWH HMONG DIGIT SEVEN 𖭗\n"
"PAHAWH HMONG DIGIT EIGHT 𖭘\n"
"PAHAWH HMONG DIGIT NINE 𖭙\n"
"MATHEMATICAL BOLD DIGIT ZERO 𝟎\n"
"MATHEMATICAL BOLD DIGIT ONE 𝟏\n"
"MATHEMATICAL BOLD DIGIT TWO 𝟐\n"
"MATHEMATICAL BOLD DIGIT THREE 𝟑\n"
"MATHEMATICAL BOLD DIGIT FOUR 𝟒\n"
"MATHEMATICAL BOLD DIGIT FIVE 𝟓\n"
"MATHEMATICAL BOLD DIGIT SIX 𝟔\n"
"MATHEMATICAL BOLD DIGIT SEVEN 𝟕\n"
"MATHEMATICAL BOLD DIGIT EIGHT 𝟖\n"
"MATHEMATICAL BOLD DIGIT NINE 𝟗\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT ZERO 𝟘\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT ONE 𝟙\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT TWO 𝟚\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT THREE 𝟛\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT FOUR 𝟜\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT FIVE 𝟝\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT SIX 𝟞\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT SEVEN 𝟟\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT EIGHT 𝟠\n"
"MATHEMATICAL DOUBLE-STRUCK DIGIT NINE 𝟡\n"
"MATHEMATICAL SANS-SERIF DIGIT ZERO 𝟢\n"
"MATHEMATICAL SANS-SERIF DIGIT ONE 𝟣\n"
"MATHEMATICAL SANS-SERIF DIGIT TWO 𝟤\n"
"MATHEMATICAL SANS-SERIF DIGIT THREE 𝟥\n"
"MATHEMATICAL SANS-SERIF DIGIT FOUR 𝟦\n"
"MATHEMATICAL SANS-SERIF DIGIT FIVE 𝟧\n"
"MATHEMATICAL SANS-SERIF DIGIT SIX 𝟨\n"
"MATHEMATICAL SANS-SERIF DIGIT SEVEN 𝟩\n"
"MATHEMATICAL SANS-SERIF DIGIT EIGHT 𝟪\n"
"MATHEMATICAL SANS-SERIF DIGIT NINE 𝟫\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT ZERO 𝟬\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT ONE 𝟭\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT TWO 𝟮\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT THREE 𝟯\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT FOUR 𝟰\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT FIVE 𝟱\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT SIX 𝟲\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT SEVEN 𝟳\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT EIGHT 𝟴\n"
"MATHEMATICAL SANS-SERIF BOLD DIGIT NINE 𝟵\n"
"MATHEMATICAL MONOSPACE DIGIT ZERO 𝟶\n"
"MATHEMATICAL MONOSPACE DIGIT ONE 𝟷\n"
"MATHEMATICAL MONOSPACE DIGIT TWO 𝟸\n"
"MATHEMATICAL MONOSPACE DIGIT THREE 𝟹\n"
"MATHEMATICAL MONOSPACE DIGIT FOUR 𝟺\n"
"MATHEMATICAL MONOSPACE DIGIT FIVE 𝟻\n"
"MATHEMATICAL MONOSPACE DIGIT SIX 𝟼\n"
"MATHEMATICAL MONOSPACE DIGIT SEVEN 𝟽\n"
"MATHEMATICAL MONOSPACE DIGIT EIGHT 𝟾\n"
"MATHEMATICAL MONOSPACE DIGIT NINE 𝟿\n"
"NYIAKENG PUACHUE HMONG DIGIT ZERO 𞅀\n"
"NYIAKENG PUACHUE HMONG DIGIT ONE 𞅁\n"
"NYIAKENG PUACHUE HMONG DIGIT TWO 𞅂\n"
"NYIAKENG PUACHUE HMONG DIGIT THREE 𞅃\n"
"NYIAKENG PUACHUE HMONG DIGIT FOUR 𞅄\n"
"NYIAKENG PUACHUE HMONG DIGIT FIVE 𞅅\n"
"NYIAKENG PUACHUE HMONG DIGIT SIX 𞅆\n"
"NYIAKENG PUACHUE HMONG DIGIT SEVEN 𞅇\n"
"NYIAKENG PUACHUE HMONG DIGIT EIGHT 𞅈\n"
"NYIAKENG PUACHUE HMONG DIGIT NINE 𞅉\n"
"WANCHO DIGIT ZERO 𞋰\n"
"WANCHO DIGIT ONE 𞋱\n"
"WANCHO DIGIT TWO 𞋲\n"
"WANCHO DIGIT THREE 𞋳\n"
"WANCHO DIGIT FOUR 𞋴\n"
"WANCHO DIGIT FIVE 𞋵\n"
"WANCHO DIGIT SIX 𞋶\n"
"WANCHO DIGIT SEVEN 𞋷\n"
"WANCHO DIGIT EIGHT 𞋸\n"
"WANCHO DIGIT NINE 𞋹\n"
"NAG MUNDARI DIGIT ZERO 𞓰\n"
"NAG MUNDARI DIGIT ONE 𞓱\n"
"NAG MUNDARI DIGIT TWO 𞓲\n"
"NAG MUNDARI DIGIT THREE 𞓳\n"
"NAG MUNDARI DIGIT FOUR 𞓴\n"
"NAG MUNDARI DIGIT FIVE 𞓵\n"
"NAG MUNDARI DIGIT SIX 𞓶\n"
"NAG MUNDARI DIGIT SEVEN 𞓷\n"
"NAG MUNDARI DIGIT EIGHT 𞓸\n"
"NAG MUNDARI DIGIT NINE 𞓹\n"
"ADLAM DIGIT ZERO 𞥐\n"
"ADLAM DIGIT ONE 𞥑\n"
"ADLAM DIGIT TWO 𞥒\n"
"ADLAM DIGIT THREE 𞥓\n"
"ADLAM DIGIT FOUR 𞥔\n"
"ADLAM DIGIT FIVE 𞥕\n"
"ADLAM DIGIT SIX 𞥖\n"
"ADLAM DIGIT SEVEN 𞥗\n"
"ADLAM DIGIT EIGHT 𞥘\n"
"ADLAM DIGIT NINE 𞥙\n"
"SEGMENTED DIGIT ZERO 🯰\n"
"SEGMENTED DIGIT ONE 🯱\n"
"SEGMENTED DIGIT TWO 🯲\n"
"SEGMENTED DIGIT THREE 🯳\n"
"SEGMENTED DIGIT FOUR 🯴\n"
"SEGMENTED DIGIT FIVE 🯵\n"
"SEGMENTED DIGIT SIX 🯶\n"
"SEGMENTED DIGIT SEVEN 🯷\n"
"SEGMENTED DIGIT EIGHT 🯸\n"
"SEGMENTED DIGIT NINE 🯹")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.