const regex = /^(?=.{6,60}$)([A-Za-z0-9!#$%&'*+/=?^_`{|}~-])([A-Za-z0-9.!#$%&'*+/=?^_`{|}~-])*[@]([A-Za-z0-9.\-])([A-Za-z0-9.\-])*[.][A-Za-z.]{2,6}\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{6,60}$)([A-Za-z0-9!#$%&\'*+\/=?^_`{|}~-])([A-Za-z0-9.!#$%&\'*+\/=?^_`{|}~-])*[@]([A-Za-z0-9.\\-])([A-Za-z0-9.\\-])*[.][A-Za-z.]{2,6}\\s*$', 'gm')
const str = `test1.test123@testtesttest.com
test1.test123@testtesttest.com
test1.test123@testtesttest.com
more_than_60_chars@testtesttest.com
test1.test123@testtesttest.com m
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}