import re
regex = re.compile(r"\b((?=[MDCLXVI])M{0,3}(C[MD]|D?C{0,3})(X[CL]|L?X{0,3})(I[XV]|V?I{0,3}))\b|\b\d+\b", flags=re.IGNORECASE)
test_str = "DILIGENTLY XII COMPARED WITH VII THE HEBREW 2, GREEK, 12 AND OTHER EDITIONS IN DIVERS LANGUAGES"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")