# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^
\n]+"
test_str = ("The client requires photos of a radioactive world
Reach the target planet.\n"
"The client requires photos.

Reach the target planet.\n"
"The client requires photos of a desert world
Reach the target planet.\n"
"The client requires photos of an airless world. Reach the target planet.\n"
"The client requires photos of a strange world

Reach the target planet
Make a quick scan.")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.