$re = '/^\d{1,3} (?<PartNum>.*?)\n(?<Description>(?:.|\n)+?)(?=^\d{1,3})/mi';
$str = '1 HUY-12
Description line 1 for the HUY-12
2 JIU-14
Description line 1 for the JIU-14
This one has 2 lines of description
3 KOI-10
Description line 1 for the KOI-10
Second description line
Third description line
4 GYT4
Description line 1 for the GYT4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);