$re = '/^[a-zA-Z0-9](?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])(?=\D*[0-9])(?=[^-+_!@#$%^&*.,?]*[-+_!@#$%^&*.,?])[-+_!@#$%^&*.,?a-zA-Z0-9]{7,}$/m';
$str = 'ABcAcs!12
9A9a$adfa
ABcAcs!
9A9a$ad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);