use strict;
my $str = '["Key:"Value""]';
my $regex = qr/^.*?"(.*)".*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";