re = /(?<=source\s)(.*):(.*)\sd/m
str = 'TCP source 12.168.189.167:32806 destination 1.78.5.128:65247, idle 0:00:00, bytes 74, flags UIO
TCP source 192.168.189.167:80 destination 137.78.5.128:65233, idle 0:00:03, bytes 334516, flags UIO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end