$re = '/(?<=-)\d+/m';
$str = 'D101-103
A1201-12203s
RR101-1033
21wD1201-1303
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);