re = /\s(?=\w+:)/m
str = 'Add id:15 singer:"Tarkan" name:"Adimi Kalbine Yaz" year:2010 count:10 price:20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end