package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)idata|quanthouse`)
var str = `idata
quanthouse
reuters
bloomberg
fidelity
nasdaq`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}