$re = '/(n(a|ă)scut(a|ă)?)|((domiciliat(a|ă)?)|(domiciliul))/m';
$str = 'nascut la
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);