import re
regex = re.compile(r"([0-9A-Za-z()]+):\s*([0-9A-Za-z()]+\s?[0-9A-Za-z()]+[\n])", flags=re.MULTILINE)
test_str = ("OK\n"
"AT!GSTATUS?\n"
"!GSTATUS:\n"
"Current Time: 2420 Temperature: 30\n"
"Reset Counter: 1 Mode: ONLINE\n"
"System mode: LTE PS state: Attached\n"
"LTE band: B30 LTE bw: 10 MHz\n"
"LTE Rx chan: 1234 LTE Tx chan: 12345\n"
"LTE CA state: NOT ASSIGNED\n"
"EMM state: Registered Normal Service\n"
"RRC state: RRC Idle\n"
"IMS reg state: No Srv\n\n"
"PCC RxM RSSI: -74 RSRP (dBm): -103\n"
"PCC RxD RSSI: -74 RSRP (dBm): -104\n"
"Tx Power: 0 TAC: 123A (1234)\n"
"RSRQ (dB): -12.4 Cell ID: 1234AB56 (12345678)\n"
"SINR (dB): 9.4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")