$re = '/[a-zA-Z]+(?![a-zA-Z])(?<!banana)/m';
$str = '0827banana82/+wine22green-729';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);