#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[EXL](?:\d[ -])?\d+(?!\S)"
Local $sString = "BL460c G6 X5550 6G 1P Svr " & @CRLF & _
"BL460c G6 E5540 6G 1P Svr " & @CRLF & _
"BL460c G6 E5540 6G 1P Svr " & @CRLF & _
"BL460c G6 E5530 6G 1P Svr " & @CRLF & _
"BL460c G6 L5520 6G 1P Svr " & @CRLF & _
"BL460c G6 E5520 6G 1P Svr " & @CRLF & _
"BL460c G6 E5506 6G 1P Svr " & @CRLF & _
"BL460c G6 E5502 6G 1P Svr " & @CRLF & _
"BL280c G6 L5520 2G LP 1P Svr " & @CRLF & _
"BL280c G6 E5520 2G 1P Svr " & @CRLF & _
"BL280c G6 E5540 2G 1P Svr " & @CRLF & _
"BL280c G6 E5502 2G 1P Svr " & @CRLF & _
"S-Buy BL460c G6 E5540 8G 2P Svr " & @CRLF & _
"S-Buy BL460c G6 E5530 4G 1P Svr " & @CRLF & _
"S-Buy BL460c G6 E5530 4G 1P Svr " & @CRLF & _
"BL2x220c G6 E5540 24G 2P 250GB Svr " & @CRLF & _
"BL2x220c G6 E5530 24G 2P 250GB Svr " & @CRLF & _
"BL2x220c G6 L5530 24G 2P 250GB Svr " & @CRLF & _
"BL2x220c G6 L5520 24G 2P " & @CRLF & _
"BL2x220c G6 E5640 2x2P 24G Svr " & @CRLF & _
"BL2x220c G6 E5630 2x2P 24G Svr " & @CRLF & _
"BL2x220c G6 L5640 2x2P 24G Svr " & @CRLF & _
"BL2x220c G6 Mod0 Svr " & @CRLF & _
"BL280c G6 X5650 6G 1P Svr " & @CRLF & _
"BL280c G6 E5630 4G 1P Svr " & @CRLF & _
"BL280c G6 L5640 4G 1P Svr " & @CRLF & _
"BL280c G6 E5506 2G 1P Svr " & @CRLF & _
"BL620c G7 E7-2860 32G Svr " & @CRLF & _
"BL620c G7 E7-2850 32G Svr " & @CRLF & _
"BL620c G7 E7-2830 32G Svr " & @CRLF & _
"BL680c G7 E7-4860 64G Svr " & @CRLF & _
"BL680c G7 E7-4860 64G Svr " & @CRLF & _
"BL680c G7 E7-4850 64G Svr " & @CRLF & _
"BL680c G7 E7-4830 64G Svr" & @CRLF & _
"BL680c G7 E7 4830 64G Svr|"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")